当前位置:首页 > 个人杂谈 > 正文内容

delhpi不能装载包rtl70的解决办法

日期: 2019-06-01 | 分类: 个人杂谈 | 浏览: 483次

delphi是一个老的开发工具,相信现在已经很少人使用了,一些项目的维护还需要使用上。而今就碰到一个项目因在D7安装过的控件,在D6下就无法安装,提示如下:

delhpi不能装载包rtl70的解决办法

翻译出来的意思大概就是:无法加载包“rtl70”。它包含单元“system”,该单元也包含在包“rtl60”中。

原因很明显了,就是该安装包已经在Delphi7安装过,并写入了单无“system”,因此,在Delphi6下无法安装,那么,碰到不能装载包rtl70的情况如何解决呢?

其实,Delphi安装控件有多种,除以dpk包安装外,我们可以直接打开pas文件方式安装,具体步骤如下:

1、打开菜单Component→Install Component..

Install Component

2、选择所安装的pas文件

选择pas文件

3、选择文件后,按下OK按键

4、然后就可看到弹出安装成功的提示

安装成功的提示

按以上方法可以完美解不能装载包rtl70的问题,同时能将一个控件分别安装在D6与D7中,好了,今天就写到这里,希望这篇文章对你有所帮助!

文章由葛一速博客原创,转载请注明出处:http://www.geyisu.com/797.html

  • 评论:(0)

已有 0 位网友发表了一针见血的评论,你还等什么?

◎欢迎大家参与讨论

站内搜索